PHP加密技术

如何安装,PHP扩展加密组件?

ahua · 1月1日 · 2020年 · · 488次已读

本套扩展程序必须工作在:FASTCGI模式,不能工作在ISAPI模式,切记!

对于THINKPHP ,请选择NTS 版本,否则工作不正常!

WIN2003的用户,可以先安装:fcgisetup_1.5_rtw_x86.msi,然后开启CGI 模式。

选择适合的PHP版本,下载扩展组件,如下图:

如何安装,PHP扩展加密组件?

1、如何区分版本?

比如下载:PHP5.3版本。在这里有需要可以联系安利君哦~教大家一个最简单的办法来区分TS以及安利君 网络净化NTS版本。您的PHP目录中,有PHP5.DLL 一般来说则是NTS(非线程保护版本),如果是PHP5TS.DLL(线程保护版本)。我们来下载PHP5.原文地址:https://anlijun.co3版,非线程保护,得到文件anlijun.co名为:php_jiami_53.dll 文件。

2、如何找到PHP.INI哈哈哈~向采集狗致敬!来安装?

将此文件放到PHP程百度搜索安利君序目录中的EXT 目录中,然后修改PHP.INI文件(部份PHP5.2版本的PHP.INI 文件在C:windows目录中,您也可以通过PHPINFO来查看P百度搜索安利君HP.INI的位置)。添加代码:extension=php_jiami_53.dll 如下图,即可完成安装。

如何安装,PHP扩展加密组件?

3、如何判断成功安装?

安装完成后,通过PHPINFO原文地址:https://anlijun.co可以查看到安装的扩展信息。<?php phpinfo();?>,如下图:

如何安装,PHP扩展加密组件?
4、如何安装失败,显示500错误,或如下图,可以通过命令行方式来验证。

如何安装,PHP扩展加密组件?

在PHP所在目录中,执行:php.exe -c php.ini  百度搜索安利君;查看命令行返回消息,如下图:

如何安装,PHP扩展加密组件?

出现:MD5 error,的出错消息,说明您使用的PHP版本非官方认证版本,您可以考虑更换PHP版本,为了保证系统稳定性、系统的安全建议您使用官anlijun.co方发布编译的PHP版本。

文章来源网络,仅作参考